The following matrix shows which minimum version of Java is necessary to run a specific Weka version. The latest official releases of Weka require Java 8 or later.

Note that if you are using Windows and your computer has a display with high pixel density (HiDPI), you may need to use Java 9 or later to avoid problems with inappropriate scaling of Weka's graphical user interfaces.

Weka Java 1.4 Java 5 Java 6 Java 7 Java 8 or later
<3.4.0
3.4.x
3.5.x <3.5.3
3.6.x
3.7.x 3.7.0 <3.7.14
3.8.x <3.8.2
3.9.x <3.9.2